Back to overview
Downtime
Cloudflare outage
Nov 18 at 08:08am PST
Affected services
Dashboard
API
Resolved
Nov 18 at 08:35am PST
Cloudflare has fully recovered and errors have subsided.
Affected services
Created
Nov 18 at 08:08am PST
Our authentication provider is currently experiencing an outage due to a broader Cloudflare incident. As a result, users may be unable to log in to the SpecCheck dashboard.
We are actively monitoring the situation and will provide an update as soon as the Cloudflare outage is resolved.
Affected services